OpenRoads Designer CONNECT Edition SDK Help

Alignment Class

Definition

Namespace: Bentley.CifNET.GeometryModel.SDK Assembly: Bentley.CifNET.GeometryModel.SDK.4.0 (in Bentley.CifNET.GeometryModel.SDK.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public abstractclass Alignment : FeaturizedModelEntity
Inheritance → ConsensusItem → ModelEntityNamedModelEntityFeaturizedModelEntity → Alignment
Derived Bentley.CifNET.GeometryModel.SDK.AlignmentProxy

Constructors

Alignment Initializes a new instance of the Alignment class

Properties

ActiveLinearEntity3d  
ActiveProfile  
ActiveSpeedTable  
BaseLinearGeometry  
Cants  
Geometry  
IsIntervalAlignment  
KeyStationSetList  
LinearAssociatedSpaces  
LinearGeometry  
LongSectionSpace  
Profiles  
SchemaName  
SightVisibilitySections  
Stationing  
SuperElevationSections  
SuperElevationSpace  

Methods

_AddKeyStationList  
_AddStationEquation  
_AddStationing(StationingMethod)  
_AddStationing(Double, Double, StationingMethod)  
_AddStationing(Double, Double, Boolean)  
_ClearActiveProfile  
_CreateCorridorByAlignment  
_CreateProfileByConstElevation  
_CreateProfileByProfileElement  
_CreateProfileByVerticalPIs  
_CreateSpeedTable  
_RemoveAllIntervals  
_RemoveInterval  
_RemoveKeyStationList  
_RenameKeyStationList  
_SetActiveProfile(Profile)  
_SetActiveProfile(Profile, StrokingParametersInfo, LinearEntity3d)  
_SetActiveProfileEntityByTemplate  
_SetFeatureDefinition(FeatureDefinition)  
_SetFeatureDefinition(String)  
_SetFeatureDefinition(String, String)  
_SetLinearGeometry  
_SetName  
AddKeyStationList  
AddStationEquation  
AddStationing(StationingMethod)  
AddStationing(Double, Double, StationingMethod)  
AddStationing(Double, Double, Boolean)  
ClearActiveProfile  
CreateCorridorByAlignment  
CreateFromElement  
CreateProfileByConstElevation  
CreateProfileByProfileElement  
CreateProfileByVerticalPIs  
CreateSpeedTable  
GetKeyStationListByName  
GetKeyStationPointListByName  
GetNativeP  
GetXSCutPoints(DgnModelRef, Double, Double, Double, Double, Alignment.WhichFeatures)  
GetXSCutPoints(DgnModelRef, Double, Double, Double, Double, Alignment.WhichFeatures, IEnumerable(String))  
RemoveAllIntervals  
RemoveInterval  
RemoveKeyStationList  
RenameKeyStationList  
SetActiveProfile(Profile)  
SetActiveProfile(Profile, StrokingParametersInfo, LinearEntity3d)  
SetActiveProfileEntityByTemplate  
SetFeatureDefinition(FeatureDefinition)  
SetFeatureDefinition(String)  
SetFeatureDefinition(String, String)  
SetLinearGeometry  
SetName  

Fields


See Also